View Full Version : Progress NOT Saved

11-24-2015, 09:53 PM
I am glad that the new update helped solve quite a few things but there are still some huge problems which I do not know how no one has talked about them yet. First and foremost, at the story mode, I'm at Vermillion Castle, but whenever I tried doing a heroic quest to get some more levels, the progress would not be saved, no matter how many times I went through the checkpoint. I tried it in many levels and still, nothing. I don't know if it's due to the fact that I'm in the middle of another quest, but I don't think it should be happening... Also, at the desert, I couldn't finish the side quest (finding the three boys) before finishing the actual mission. I found the third boy after finishing the quest, but it wouldn't let me talk to Kaylin to complete the side quest! I don't know if anyone else is facing those problems, but they should be fixed as soon as possible.

[K] Hugo
11-25-2015, 05:32 PM
Hello Kostis, thank you for your detailed feedback!

Have you sent a ticket containing these details to the support team, using the following link? https://nexus.kobojo.com/Support
Thank you in advance!