PDA

View Full Version : What are the System Requirements to Play Zodiac?



[K] Allen Bernard
12-07-2015, 05:09 PM
Recommended hardware is the following:

iPhone5s and above
iPad air/mini 2 and above

WILL NOT WORK FOR EARLIER DEVICES